#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d{2}(\d{2})?\/\d{2}\/\d{2}(\d{2})?)|(\d{2}:\d{2}(:\d{2})?)"
Local $sString = "----------17/01/01----------00:00:00-----" & @CRLF & _
"-----17/02/02 09:03----------------------" & @CRLF & _
"--------------------34:23----------------" & @CRLF & _
"-----17/02/04 11:09:24-------------------" & @CRLF & _
"------------------17/04/27---------------" & @CRLF & _
"-----------------------------------------" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")