re = /(\d{2}(\d{2})?\/\d{2}\/\d{2}(\d{2})?)|(\d{2}:\d{2}(:\d{2})?)/
str = '----------17/01/01----------00:00:00-----
-----17/02/02 09:03----------------------
--------------------34:23----------------
-----17/02/04 11:09:24-------------------
------------------17/04/27---------------
-----------------------------------------
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end