using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"0{4}:(?:0[^0]|[^0]\d):.*";
string input = @"0000:00:01.0
0000:03:00.0
0000:04:00.0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}