const regex = /0{4}:(?:0[^0]|[^0]\d):.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0{4}:(?:0[^0]|[^0]\\d):.*', 'gm')
const str = `0000:00:01.0
0000:03:00.0
0000:04:00.0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}