$re = '/0{4}:(?:0[^0]|[^0]\d):.*/m';
$str = '0000:00:01.0
0000:03:00.0
0000:04:00.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);