// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)0{4}:(?:0[^0]|[^0]\d):.*").unwrap();
let string = "0000:00:01.0
0000:03:00.0
0000:04:00.0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}