package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)0{4}:(?:0[^0]|[^0]\d):.*`)
var str = `0000:00:01.0
0000:03:00.0
0000:04:00.0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}