#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:0(?:1(?:2|)|2(?:1|)|)|1(?:0(?:2|)|2(?:0|)|)|2(?:0(?:1|)|1(?:0|)|))$"
Local $sString = "Should pass:" & @CRLF & _
"0" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"01" & @CRLF & _
"012" & @CRLF & _
"120" & @CRLF & _
"210" & @CRLF & _
"201" & @CRLF & _
"102" & @CRLF & _
"" & @CRLF & _
"Should not pass:" & @CRLF & _
"101" & @CRLF & _
"111" & @CRLF & _
"121" & @CRLF & _
"0212"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")