package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:0(?:1(?:2|)|2(?:1|)|)|1(?:0(?:2|)|2(?:0|)|)|2(?:0(?:1|)|1(?:0|)|))$`)
var str = `Should pass:
0
1
2
01
012
120
210
201
102
Should not pass:
101
111
121
0212`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}