const regex = /^(?:0(?:1(?:2|)|2(?:1|)|)|1(?:0(?:2|)|2(?:0|)|)|2(?:0(?:1|)|1(?:0|)|))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:0(?:1(?:2|)|2(?:1|)|)|1(?:0(?:2|)|2(?:0|)|)|2(?:0(?:1|)|1(?:0|)|))$', 'gm')
const str = `Should pass:
0
1
2
01
012
120
210
201
102
Should not pass:
101
111
121
0212`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}