use strict;
my $str = 'Should pass:
0
1
2
01
012
120
210
201
102
Should not pass:
101
111
121
0212';
my $regex = qr/^(?:0(?:1(?:2|)|2(?:1|)|)|1(?:0(?:2|)|2(?:0|)|)|2(?:0(?:1|)|1(?:0|)|))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}