$re = '/^(?:0(?:1(?:2|)|2(?:1|)|)|1(?:0(?:2|)|2(?:0|)|)|2(?:0(?:1|)|1(?:0|)|))$/m';
$str = 'Should pass:
0
1
2
01
012
120
210
201
102
Should not pass:
101
111
121
0212';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);