using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^0-9]+)([0-9]+)\.([0-9]+)\.([^.]+)\.(.+)$";
string input = @"FNBR6.03202021.Default_Title.mp4
GEVY230.03182021.Project76.mp4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}