package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^0-9]+)([0-9]+)\.([0-9]+)\.([^.]+)\.(.+)$`)
var str = `FNBR6.03202021.Default_Title.mp4
GEVY230.03182021.Project76.mp4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}