$re = '/^([^0-9]+)([0-9]+)\.([0-9]+)\.([^.]+)\.(.+)$/m';
$str = 'FNBR6.03202021.Default_Title.mp4
GEVY230.03182021.Project76.mp4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);