import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^0-9]+)([0-9]+)\\.([0-9]+)\\.([^.]+)\\.(.+)$";
final String string = "FNBR6.03202021.Default_Title.mp4\n"
+ "GEVY230.03182021.Project76.mp4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}