re = /^([^0-9]+)([0-9]+)\.([0-9]+)\.([^.]+)\.(.+)$/m
str = 'FNBR6.03202021.Default_Title.mp4
GEVY230.03182021.Project76.mp4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end