import re
regex = re.compile(r"\S+(?:[ ]{1,49}\S+)*", flags=re.MULTILINE)
test_str = ("All: Day and Night Vulnerabilities\\\\Personnel vulnerabilities\\\\Outdoor vulnerability 1E-09 /AvgeYear \\x1a'\n\n"
"All: Day and Night\n"
"All: Day and Night")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")