#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)test:.*?(?=$|\b\w+:)"
Local $sString = "This is a test: 1, two again,three test2: what is, this" & @CRLF & _
"test: acid, kool-aid word: some more info" & @CRLF & _
"Another test: face, 3, & yes"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)