using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"test:.*?(?=$|\b\w+:)";
string substitution = @"";
string input = @"This is a test: 1, two again,three test2: what is, this
test: acid, kool-aid word: some more info
Another test: face, 3, & yes";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}