import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "test:.*?(?=$|\\b\\w+:)";
final String string = "This is a test: 1, two again,three test2: what is, this\n"
+ "test: acid, kool-aid word: some more info\n"
+ "Another test: face, 3, & yes";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}