$re = '/test:.*?(?=$|\b\w+:)/m';
$str = 'This is a test: 1, two again,three test2: what is, this
test: acid, kool-aid word: some more info
Another test: face, 3, & yes';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;