const regex = /test:.*?(?=$|\b\w+:)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('test:.*?(?=$|\\b\\w+:)', 'gm')
const str = `This is a test: 1, two again,three test2: what is, this
test: acid, kool-aid word: some more info
Another test: face, 3, & yes`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);