#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\*\*Bewerbung von .*:\*\*\n\n\*Name:\* .*\n\*MC-Name:\* .*\n\*Alter:\* .*\n\*Aufgabe:\* .*\n\*Vorteile:\* .*\n\*Gründe:\* .*(*SKIP)(*F)|.+)$"
Local $sString = "Change Regex to negative" & @CRLF & _
"" & @CRLF & _
"Need help with a regex. I have a discord server where I use Sapphire (a discord bot) for applications. The normal regex for the normal application works, just not the one where it should check for messages that do NOT fit the template." & @CRLF & _
"Here's the normal one (that works):" & @CRLF & _
"" & @CRLF & _
"**Bewerbung von :**" & @CRLF & _
"" & @CRLF & _
"*Name:* " & @CRLF & _
"*MC-Name:* " & @CRLF & _
"*Alter:* " & @CRLF & _
"*Aufgabe:* " & @CRLF & _
"*Vorteile:* " & @CRLF & _
"*Gründe:* " & @CRLF & _
"" & @CRLF & _
"And here the other that doesn't work and that should check for message that don't fit the template:" & @CRLF & _
"" & @CRLF & _
"```^(?!.*(?:Bewerbung von|Name:|MC-Name:|Alter:|Aufgabe:|Vorteile:|Gründe:)).*$```" & @CRLF & _
"" & @CRLF & _
"Can someone help me? I just want the secon regex to check for messages that do not contain these words ("Bewerbung von", "Name:", etc.)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")