const regex = /^(\*\*Bewerbung von .*:\*\*\n\n\*Name:\* .*\n\*MC-Name:\* .*\n\*Alter:\* .*\n\*Aufgabe:\* .*\n\*Vorteile:\* .*\n\*Gründe:\* .*(*SKIP)(*F)|.+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\*\\*Bewerbung von .*:\\*\\*\\n\\n\\*Name:\\* .*\\n\\*MC-Name:\\* .*\\n\\*Alter:\\* .*\\n\\*Aufgabe:\\* .*\\n\\*Vorteile:\\* .*\\n\\*Gründe:\\* .*(*SKIP)(*F)|.+)$', 'gm')
const str = `Change Regex to negative
Need help with a regex. I have a discord server where I use Sapphire (a discord bot) for applications. The normal regex for the normal application works, just not the one where it should check for messages that do NOT fit the template.
Here's the normal one (that works):
**Bewerbung von :**
*Name:*
*MC-Name:*
*Alter:*
*Aufgabe:*
*Vorteile:*
*Gründe:*
And here the other that doesn't work and that should check for message that don't fit the template:
\`\`\`^(?!.*(?:Bewerbung von|Name:|MC-Name:|Alter:|Aufgabe:|Vorteile:|Gründe:)).*\$\`\`\`
Can someone help me? I just want the secon regex to check for messages that do not contain these words ("Bewerbung von", "Name:", etc.)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}