$re = '/^(\*\*Bewerbung von .*:\*\*\n\n\*Name:\* .*\n\*MC-Name:\* .*\n\*Alter:\* .*\n\*Aufgabe:\* .*\n\*Vorteile:\* .*\n\*Gründe:\* .*(*SKIP)(*F)|.+)$/m';
$str = 'Change Regex to negative
Need help with a regex. I have a discord server where I use Sapphire (a discord bot) for applications. The normal regex for the normal application works, just not the one where it should check for messages that do NOT fit the template.
Here\'s the normal one (that works):
**Bewerbung von :**
*Name:*
*MC-Name:*
*Alter:*
*Aufgabe:*
*Vorteile:*
*Gründe:*
And here the other that doesn\'t work and that should check for message that don\'t fit the template:
```^(?!.*(?:Bewerbung von|Name:|MC-Name:|Alter:|Aufgabe:|Vorteile:|Gründe:)).*$```
Can someone help me? I just want the secon regex to check for messages that do not contain these words ("Bewerbung von", "Name:", etc.)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);