use strict;
my $str = 'Change Regex to negative
Need help with a regex. I have a discord server where I use Sapphire (a discord bot) for applications. The normal regex for the normal application works, just not the one where it should check for messages that do NOT fit the template.
Here\'s the normal one (that works):
**Bewerbung von :**
*Name:*
*MC-Name:*
*Alter:*
*Aufgabe:*
*Vorteile:*
*Gründe:*
And here the other that doesn\'t work and that should check for message that don\'t fit the template:
```^(?!.*(?:Bewerbung von|Name:|MC-Name:|Alter:|Aufgabe:|Vorteile:|Gründe:)).*$```
Can someone help me? I just want the secon regex to check for messages that do not contain these words ("Bewerbung von", "Name:", etc.)';
my $regex = qr/^(\*\*Bewerbung von .*:\*\*\n\n\*Name:\* .*\n\*MC-Name:\* .*\n\*Alter:\* .*\n\*Aufgabe:\* .*\n\*Vorteile:\* .*\n\*Gründe:\* .*(*SKIP)(*F)|.+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}