import Foundation
let pattern = #"^(\*\*Bewerbung von .*:\*\*\n\n\*Name:\* .*\n\*MC-Name:\* .*\n\*Alter:\* .*\n\*Aufgabe:\* .*\n\*Vorteile:\* .*\n\*Gründe:\* .*(*SKIP)(*F)|.+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Change Regex to negative
Need help with a regex. I have a discord server where I use Sapphire (a discord bot) for applications. The normal regex for the normal application works, just not the one where it should check for messages that do NOT fit the template.
Here's the normal one (that works):
**Bewerbung von :**
*Name:*
*MC-Name:*
*Alter:*
*Aufgabe:*
*Vorteile:*
*Gründe:*
And here the other that doesn't work and that should check for message that don't fit the template:
```^(?!.*(?:Bewerbung von|Name:|MC-Name:|Alter:|Aufgabe:|Vorteile:|Gründe:)).*$```
Can someone help me? I just want the secon regex to check for messages that do not contain these words ("Bewerbung von", "Name:", etc.)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)