#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[^\d]+\s*\K(\d+(?:\.\d+)*)"
Local $sString = "Foo 1.2.3.4.5 bar --> Captures 1.2.3.4.5" & @CRLF & _
"Foo 111111.2..3.4.5 bar --> Captures 111111.2" & @CRLF & _
"Foo 10.. bar --> Captures 10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")