const regex = /^[^\d]+\s*\K(\d+(?:\.\d+)*)/mig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\d]+\\s*\\K(\\d+(?:\\.\\d+)*)', 'mig')
const str = `Foo 1.2.3.4.5 bar --> Captures 1.2.3.4.5
Foo 111111.2..3.4.5 bar --> Captures 111111.2
Foo 10.. bar --> Captures 10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}