using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\d]+\s*\K(\d+(?:\.\d+)*)";
string input = @"Foo 1.2.3.4.5 bar --> Captures 1.2.3.4.5
Foo 111111.2..3.4.5 bar --> Captures 111111.2
Foo 10.. bar --> Captures 10";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}