$re = '/^[^\d]+\s*\K(\d+(?:\.\d+)*)/mi';
$str = 'Foo 1.2.3.4.5 bar --> Captures 1.2.3.4.5
Foo 111111.2..3.4.5 bar --> Captures 111111.2
Foo 10.. bar --> Captures 10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);