import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\d]+\\s*\\K(\\d+(?:\\.\\d+)*)";
final String string = "Foo 1.2.3.4.5 bar --> Captures 1.2.3.4.5\n"
+ "Foo 111111.2..3.4.5 bar --> Captures 111111.2\n"
+ "Foo 10.. bar --> Captures 10";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}