#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^|[^\d.\n])\d*\.\d+\b(?!\.\d)"
Local $sString = "= INT" & @CRLF & _
"123" & @CRLF & _
"+333" & @CRLF & _
"-5" & @CRLF & _
"" & @CRLF & _
"= FLOAT" & @CRLF & _
"1334.455" & @CRLF & _
".323" & @CRLF & _
"-323.323" & @CRLF & _
"+.2" & @CRLF & _
"-.34"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")