import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|[^\\d.\\n])\\d*\\.\\d+\\b(?!\\.\\d)";
final String string = "= INT\n"
+ "123\n"
+ "+333\n"
+ "-5\n\n"
+ "= FLOAT\n"
+ "1334.455\n"
+ ".323\n"
+ "-323.323\n"
+ "+.2\n"
+ "-.34";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}