const regex = /(^|[^\d.\n])\d*\.\d+\b(?!\.\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|[^\\d.\\n])\\d*\\.\\d+\\b(?!\\.\\d)', 'gm')
const str = `= INT
123
+333
-5
= FLOAT
1334.455
.323
-323.323
+.2
-.34`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}