import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/(www\\.)?vimeo.com\\/(channels\\/[a-zA-Z0-9]*\\/)?(?<id>[0-9]*)(\\/(?<hash>[a-zA-Z0-9]+))?(\\#t=(\\d+)s)?";
final String string = "https://vimeo.com/234234/sdfaeafesa\n"
+ "https://vimeo.com/234234/sdfaeafesa?embedded=true&source=vimeo_logo&owner=12342\n"
+ "https://vimeo.com/342342?h=sdfaeafesaf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}