// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https?:\/\/(www\.)?vimeo.com\/(channels\/[a-zA-Z0-9]*\/)?(?<id>[0-9]*)(\/(?<hash>[a-zA-Z0-9]+))?(\#t=(\d+)s)?").unwrap();
let string = "https://vimeo.com/234234/sdfaeafesa
https://vimeo.com/234234/sdfaeafesa?embedded=true&source=vimeo_logo&owner=12342
https://vimeo.com/342342?h=sdfaeafesaf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}