import re
regex = re.compile(r"^https?:\/\/(www\.)?vimeo.com\/(channels\/[a-zA-Z0-9]*\/)?(?<id>[0-9]*)(\/(?<hash>[a-zA-Z0-9]+))?(\#t=(\d+)s)?", flags=re.MULTILINE)
test_str = ("https://vimeo.com/234234/sdfaeafesa\n"
"https://vimeo.com/234234/sdfaeafesa?embedded=true&source=vimeo_logo&owner=12342\n"
"https://vimeo.com/342342?h=sdfaeafesaf")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")