re = /^https?:\/\/(www\.)?vimeo.com\/(channels\/[a-zA-Z0-9]*\/)?(?<id>[0-9]*)(\/(?<hash>[a-zA-Z0-9]+))?(\#t=(\d+)s)?/m
str = 'https://vimeo.com/234234/sdfaeafesa
https://vimeo.com/234234/sdfaeafesa?embedded=true&source=vimeo_logo&owner=12342
https://vimeo.com/342342?h=sdfaeafesaf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end