const regex = /^https?:\/\/(www\.)?vimeo.com\/(channels\/[a-zA-Z0-9]*\/)?(?<id>[0-9]*)(\/(?<hash>[a-zA-Z0-9]+))?(\#t=(\d+)s)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/(www\\.)?vimeo.com\\\/(channels\\\/[a-zA-Z0-9]*\\\/)?(?<id>[0-9]*)(\\\/(?<hash>[a-zA-Z0-9]+))?(\\#t=(\\d+)s)?', 'gm')
const str = `https://vimeo.com/234234/sdfaeafesa
https://vimeo.com/234234/sdfaeafesa?embedded=true&source=vimeo_logo&owner=12342
https://vimeo.com/342342?h=sdfaeafesaf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}