#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bsource(?::|=)(?:"(?P<value1>[^"]+)"|(?P<value2>\S+))"
Local $sString = "... source="source name with quotes - special characters also" ..." & @CRLF & _
"" & @CRLF & _
"... source=source_name_without_quotes_with_special-characters* ..." & @CRLF & _
"" & @CRLF & _
"... source="source_name_with_quotes_no_spaces-*" ..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")