$re = '~\bsource(?::|=)(?:"(?P<value1>[^"]+)"|(?P<value2>\S+))~m';
$str = '... source="source name with quotes - special characters also" ...
... source=source_name_without_quotes_with_special-characters* ...
... source="source_name_with_quotes_no_spaces-*" ...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);