re = /\bsource(?::|=)(?:"(?P<value1>[^"]+)"|(?P<value2>\S+))/m
str = '... source="source name with quotes - special characters also" ...
... source=source_name_without_quotes_with_special-characters* ...
... source="source_name_with_quotes_no_spaces-*" ...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end