using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bsource(?::|=)(?:""(?P<value1>[^""]+)""|(?P<value2>\S+))";
string input = @"... source=""source name with quotes - special characters also"" ...
... source=source_name_without_quotes_with_special-characters* ...
... source=""source_name_with_quotes_no_spaces-*"" ...";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}