using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^val:\s*([^-\n]*?)(?:\s*-[^-]*-\s*(.*))?$";
string input = @"val: 1.25MG - OM - PO/TUBE
val:2.5 MG - OM - PO/TUBE
val: 18 UNITS(S)
val: 850 MG - TDS AFTER FOOD - SC (SUBCUTANEOUS)
val: 75 MG - OM - PO/TUBE";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}