const regex = new RegExp('^val:\\s*([^-\\n]*?)(?:\\s*-[^-]*-\\s*(.*))?$', 'gm')
const str = `val: 1.25MG - OM - PO/TUBE
val:2.5 MG - OM - PO/TUBE
val: 18 UNITS(S)
val: 850 MG - TDS AFTER FOOD - SC (SUBCUTANEOUS)
val: 75 MG - OM - PO/TUBE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}