use strict;
my $str = 'val: 1.25MG - OM - PO/TUBE
val:2.5 MG - OM - PO/TUBE
val: 18 UNITS(S)
val: 850 MG - TDS AFTER FOOD - SC (SUBCUTANEOUS)
val: 75 MG - OM - PO/TUBE';
my $regex = qr/^val:\s*([^-\n]*?)(?:\s*-[^-]*-\s*(.*))?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}