import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^val:\\s*([^-\\n]*?)(?:\\s*-[^-]*-\\s*(.*))?$";
final String string = "val: 1.25MG - OM - PO/TUBE\n"
+ "val:2.5 MG - OM - PO/TUBE\n"
+ "val: 18 UNITS(S)\n"
+ "val: 850 MG - TDS AFTER FOOD - SC (SUBCUTANEOUS)\n"
+ "val: 75 MG - OM - PO/TUBE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}