re = /^val:\s*([^-\n]*?)(?:\s*-[^-]*-\s*(.*))?$/m
str = 'val: 1.25MG - OM - PO/TUBE
val:2.5 MG - OM - PO/TUBE
val: 18 UNITS(S)
val: 850 MG - TDS AFTER FOOD - SC (SUBCUTANEOUS)
val: 75 MG - OM - PO/TUBE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end